2007年1月26日 星期五

[網路管理] CCNA考試準備整理 - CH4

CCNA 認證教戰手冊

CH4. Cisco IOS簡介

一. 登入、登出

1. 使用者exec模式:(>)
logout

2. 特權exec模式:(#)
enable ; en
disable

3. 進入路由器設定模式(#)
configure terminal ; config t ; config
à 變更DRAM
configure memory ; config mem
à 變更NVRAM
configure network ; config net
à 變更 TFTP 主機中的路由器組態
*
以上3種方式, 都是用來設定資訊到路由器之RAM中的命令, 但通常只使用configure terminal命令。

二. 顯示、查詢(使用者模式 or 特權模式)

1. 查詢系統軟硬體版本
show version;sh version

2. 查詢前10個輸入命令
show history ; sh history

3. 查詢終端機設定
show terminal ; sh terminal

4. 查詢路由器的序列界面否連結有DCE纜線
sh controllers s 0/0

5. 查詢目前DRAM中的組態
show running-config ; sh run

6. 查詢目前NVRAM中的組態
show startup-config ; sh start

7. 公用程式
ping
telnet
traceroute

8. 找尋鄰居的網路位址
show cdp entry * protocol

9. 查詢介面
sh int fa0/0
sh int s0/0
*keepalive,
預設為10,每部路由器每隔10秒會傳送keepalive訊息給鄰居, 如果兩部路由器沒有設定相同的keepalive間隔, 就無法運作。

10. 查詢介面第3層設定的資訊
sh ip interface

11. 查詢介面精簡概要
sh ip int brief

12. 查詢介面第1層及第2層的狀態
sh protocols

13. 查詢介面本身的相關資訊
sh controllers

三. 特權操作

1. 組態的儲存
copy running-config startup-config
*
這個命令要求目的檔名時, 預設的答案是startup-config, 也不能輸入其他名稱, 否則會數到錯誤訊息。

2. 刪除NVRAM中的組態(特權模式)
erase startup-config
*
如果使用erase startup-config 命令之後, 重新載入或關機再啟動路由器, 則畫面會提供「裝配模式」。

3. 重新載入(特權模式)
reload

4. 清除介面計數器
clear counters s0/0

四. 組態設定:(config)

1. 設定日期時間
clock set 10:30:10 28 august 2006

2. 改變緩衝區大小
terminal history size 256

3. 改變路由器名稱
hostname Todd

4. 改變MOTD標題訊息
banner motd #
標題訊息>
#

5. 改變Exec標題訊息

6. 改變進入的(incoming)標題訊息

7. 改變登入(login)標題訊息
banner login #
標題訊息>
#

五. 變更介面組態:(config)

1. 進入變更介面
interface fastethernet0/0 ; int fa0/0

2. 變更介面的說明
int fa0/0
description Sales Lan
int s0/0
desc Wan to Miami circuit : 6fdda4321

3. 設定所用的連接頭類型
int fa 0/0
media-type 100BaseX

4. 啟動界面
int fa 0/0
no shutdown

5. 設定界面的IP位址
int fa 0/0
ip address 10.1.1.5 255.255.255.0
no shut

6. 增加界面的第2IP
int fa 0/0
ip address 10.1.1.4 255.255.255.0 secondary
*
建議不要在一個界面上使用多個IP位址, 因為這樣很沒有效率

7. 設定DCE序列界面的時脈
int s0/0
clock rate 64000
*
根據預設Cisco路由器是DCE裝置, 必須設定時脈; DTE裝置則不需要

8. 改變介面的bandwidth
int fa 0/0
bandwidth 64
*Cisco
路由器出貨時, 預設的序列鏈路頻寬為T1, 但這與鏈路上傳輸無關, 僅供遶送協定(IGRPEIGRPOSPF)計算抵達遠端網路的最佳成本用的, 因此如果是使用RIP遶送, Bandwidth就不重要, 因為RIP是使用hop count來決定最佳路徑的。

9. 防止控制台因為逾時而將您踢出去
config t
line con 0
exec-timeout 0 0

10. 防止控制台訊息蓋過您正在輸入的命令
config t
line con 0
logging synchronous

六. 變更密碼:(config)

1. 變更enable密碼
enable secret cisco
enable password cisco2
*2
種密碼必須不同

2. 變更console密碼
line console 0
login
password cisco

3. 變更aux密碼
line aux 0
login
password cisco

4. 變更telnet密碼
line vty 0 4
à 0 ~ 4 vty線路
login
password cisco
*
可以使用no login命序, 開啟允許沒有密碼的telnet連線。

5. 對密碼加密
service password-encryption
*
預設上只有enable secret密碼會被加密

七. 遶送協定設定:(config)

1. 進入遶送協定設定
router rip

0 意見: